We have identified the issue in one of our switches and will proceed with rebooting it. Customers may notice timeouts or packet loss during the next 5 minutes.
Posted May 19, 2025 - 16:25 UTC
Investigating
We're observing that some servers in our NL1 location are currently experiencing network connectivity issues. We're currently gathering more information about this incident and will provide more information shortly.
Posted May 19, 2025 - 15:58 UTC
This incident affected: Enterprise Hosting and SSD KVM Servers - NL.